FLAM® Issue Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000864FL51.1 FLCLpublic2017-03-17 11:262017-03-22 08:39
ReporterFalk Reichbott 
Assigned ToMykhailo Moldavskyy 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusresolvedResolutionno change required 
PlatformGeneralOSGeneralOS VersionGeneral
Product Version5.1.14 
Target Version5.1.15Fixed in Version5.1.15 
Summary0000864: Add return code for an informational (to mark key expire and other things)
DescriptionTo parse the log for an deticated information it would be useful to get an return code (e.g. 2) which tells the calling script, that the reason for the return code must be parsed in the log.

For example if a key close to expire, then a return code 2 can be used to parse the warnings in the log, to figure out what is happen. Or send the complete log to a task id or somthing else.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001091)
Falk Reichbott (administrator)
2017-03-17 12:41

Is allready implemented. If a warning in the LOG a return code 4 is given. Only if the directory walk (wildcards) used, then the information can be lost, because a warning tells you in this case, that not all files converted correctly.
(0001094)
Falk Reichbott (administrator)
2017-03-22 08:39

If a relevant warning written to the log, then the condition code 1 will be returns by default if success. If a key close to expire, then such a relevant warning is written. A relevant warning is a warning form a used component. Warnings from components which are removed from processing are still written to the log, but not used to set the completion code 1.

With environemnt variable "FL_RETURN_IF_LOG_WARNING=OFF" you can deactivate this mechanism. On z/OS you can additional set the system variable &FLRLOGW=OFF to prevent the completion code 1 if a relevant warning in the log by default, Later you can active it over the environment variable with "ON" if required.

- Issue History
Date Modified Username Field Change
2017-03-17 11:26 Falk Reichbott New Issue
2017-03-17 11:26 Falk Reichbott Status new => assigned
2017-03-17 11:26 Falk Reichbott Assigned To => Falk Reichbott
2017-03-17 12:41 Falk Reichbott Note Added: 0001091
2017-03-17 12:41 Falk Reichbott Status assigned => resolved
2017-03-17 12:41 Falk Reichbott Fixed in Version => 5.1.15
2017-03-17 12:41 Falk Reichbott Resolution open => no change required
2017-03-17 13:26 Mykhailo Moldavskyy Status resolved => assigned
2017-03-17 13:26 Mykhailo Moldavskyy Assigned To Falk Reichbott => Mykhailo Moldavskyy
2017-03-22 08:39 Falk Reichbott Note Added: 0001094
2017-03-22 08:39 Falk Reichbott Status assigned => resolved


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker